S905W

TX3 Mini, X96 Mini, W95 to name a few...
This board has no forums.
New Topic
  • Announcements
  • Topics
  • [HELP] My X96 mini device became 1GB RAM and 8GB ROM after updating to PIE ROM
    by marioayman »
    4 Replies
    1335 Views
    Last post by em3ka
  • W95 Box Remote not work
    by euv-5820 »
    9 Replies
    796 Views
    Last post by euv-5820
  • S905W TX3 mini V1.1 bootloader
    by dalek »
    1 Replies
    711 Views
    Last post by em3ka
  • How to change w95 play store? (V2ff)
    by 27godzilla »
    0 Replies
    367 Views
    Last post by 27godzilla
  • [HELP] Bluetooth can't turn on
    by mckenzie »
    4 Replies
    951 Views
    Last post by em3ka
  • [HELP] My x96 mini is connected to PC but for few seconds then it disconnects
    by arshsingh1987 »
    5 Replies
    1257 Views
    Last post by ranjan_hjp
  • [HELP] T96 Mars
    by Alexandr1979 »
    67 Replies
    10579 Views
    Last post by aozaslan
  • Atvx v5 on x96 mini 2/16 not work dual boot.
    by bennington111 »
    0 Replies
    585 Views
    Last post by bennington111
  • Tx3 mini clock does not appear in the box
    by alinsfilho »
    30 Replies
    9896 Views
    Last post by Ferris9
  • [HELP] T95 S1 failed install
    by dMiguelp »
    2 Replies
    493 Views
    Last post by dMiguelp
  • Tanix TX3 Mini - Need some information
    by andrewly3 »
    1 Replies
    525 Views
    Last post by em3ka
  • [HELP] my TX3 mini was bricked
    by civicling »
    15 Replies
    5438 Views
    Last post by dorde73
  • [HELP] Failed install s905w_atvXperience_v2FF firmware
    by barbuslex »
    2 Replies
    4628 Views
    Last post by hkj ydvil
  • I need link for atvXperience v2* or v3, help me please
    by Inkling2016 »
    2 Replies
    568 Views
    Last post by Inkling2016
  • X96 mini 2gb not work
    by Robi12ster »
    0 Replies
    460 Views
    Last post by Robi12ster
  • [SOLVED] How to remove google setup wizard
    by justin10 »
    1 Replies
    617 Views
    Last post by em3ka
  • [HELP] x96 mini 1g ram 8 g rom
    by deetucks »
    4 Replies
    790 Views
    Last post by gieant
  • [QUESTION] 3D nand or S905l rev. B atvx
    by DreamHeroT95 »
    1 Replies
    443 Views
    Last post by em3ka
  • Beelink W95 remote Tab file
    by Techflame »
    8 Replies
    1241 Views
    Last post by Techflame
  • [HELP] How to restore the original firmware
    by isbjvijc »
    13 Replies
    1974 Views
    Last post by atvuser439857934
  • [HELP] [0x30405004]UBOOT/Partition system/Verify patition/Error result
    by Ranjha »
    0 Replies
    1391 Views
    Last post by Ranjha
  • [HELP] TX3 mini (red PCB), bricked device
    by brunnoplis »
    4 Replies
    888 Views
    Last post by brunnoplis
  • [HELP] TX9 crashed at boot
    by oikaka1 »
    3 Replies
    687 Views
    Last post by em3ka
  • TX3 Mini-A brick problem, nothing helps!!
    by kekec01 »
    3 Replies
    1122 Views
    Last post by em3ka
  • [HELP] Fix X96 mini box red light issue
    by rama »
    11 Replies
    1343 Views
    Last post by em3ka
New Topic
  • Information
  • Forum permissions

    You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum