S905X

MiBox, X96 to name a few...
This board has no forums.
New Topic
  • Announcements
  • Topics
  • [ROM] atvX v4 - AndroidTV 9.0 (S905X)
    by Nayam »
    829 Replies
    81200 Views
    Last post by bumerc
  • [ROM] Magicsee N5 - atvXperience v2 N5 Edition
    by Nayam »
    79 Replies
    50174 Views
    Last post by cuspusty
  • [DISCUSSION] Magicsee N5
    by polde66 »
    101 Replies
    53760 Views
    Last post by kikko123
  • ADTV with DVB-S2 tuner
    by AZlink »
    0 Replies
    24 Views
    Last post by AZlink
  • AURORA Android 7.1 TV BOX Amlogic S905X 2G+8G.Help
    by antonio6o6 »
    5 Replies
    125 Views
    Last post by antonio6o6
  • atvXperience v5 - X96 - IR problem
    by thorm »
    1 Replies
    178 Views
    Last post by thorm
  • Z69 2G - Installation issues
    by arcanaXknight »
    70 Replies
    14795 Views
    Last post by bumerc
  • atvx5 z69
    by lonegunman »
    1 Replies
    66 Views
    Last post by em3ka
  • D905 (S905???) android box issue
    by rfreiha »
    6 Replies
    193 Views
    Last post by rfreiha
  • atvXperience wi-fi bug
    by Macaxeira »
    2 Replies
    160 Views
    Last post by Macaxeira
  • Can't find firmware for X96mini S905X
    by Andre_ »
    0 Replies
    132 Views
    Last post by Andre_
  • [HELP] A95x MAX v 81 is dead - Try to unbrick it by UART?
    by blitz184 »
    3 Replies
    689 Views
    Last post by kobyboy1966
  • [HELP] Memobox UFO ir/bluetooth remote control
    by rojul »
    11 Replies
    3748 Views
    Last post by rojul
  • atvX v5 on Mini MXIII II
    by diegolnr »
    1 Replies
    218 Views
    Last post by em3ka
  • [HELP] MXQ PRO clone (MXQ_S95X_V2_0)
    by jimjack12 »
    4 Replies
    557 Views
    Last post by mxfreak
  • [HELP] mxq pro+ 4k 0x312e0902 check para error 4% stuck,and sdcard reset loop
    by mxfreak »
    0 Replies
    162 Views
    Last post by mxfreak
  • [HELP] s905x red light can not start
    by leadena »
    4 Replies
    353 Views
    Last post by em3ka
  • [HELP] Trying to update X96 Max
    by boliza »
    5 Replies
    413 Views
    Last post by boliza
  • [QUESTION] TX95
    by ilMarikotto »
    1 Replies
    203 Views
    Last post by em3ka
  • [HELP] Update for MAG 410
    by edisondweikat »
    7 Replies
    2313 Views
    Last post by edisondweikat
  • [QUESTION] Some issues on rom v2E
    by sasiroadies »
    7 Replies
    424 Views
    Last post by em3ka
  • [QUESTION] X96
    by atacr »
    10 Replies
    1340 Views
    Last post by Roelof
  • [QUESTION] atvxperience on Fiberhome HG680-p
    by fahmyakbar »
    8 Replies
    4309 Views
    Last post by Andrauda
  • [HELP] Firmware EM95X 2G/16G
    by Trieuthieulong »
    0 Replies
    381 Views
    Last post by Trieuthieulong
  • atvX v4.3.x ap6330
    by bumerc »
    6 Replies
    958 Views
    Last post by macrom76
New Topic
  • Information
  • Forum permissions

    You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum