[HELP] Weird S905 A95X box - No display but working

S905D, S905, S8xx Series and other box users can discuss here :)
Nayam  
Administrator & Developer
Posts: 1236
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 178 times
Been thanked: 344 times
Contact:

[HELP] Weird S905 A95X box - No display but working

#21

Post by Nayam » Sun Feb 17, 2019 11:40 am

SrWladimir wrote: ↑
Sun Feb 17, 2019 8:13 am
This will sound stupid, but you can try if you don't have anything to lose,
If you have a Heat gun, try to use it on the MOBO for a 15 seconds..
I say this because happened to me on various hardware that GPU soldering is not well made and it makes it power on but no video output or powers on but can't boot because of the GPU.
Again, only try this at last option and if you don't have anything to lose.
If you will try this, take off any plastic part and any heatsink.
Thanks, I'll try that after I check if AV output gives no signal or not
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!
My Devices:
X96 Mini, A95X Pro, H96 Pro Stick, A95X Max

Nayam  
Administrator & Developer
Posts: 1236
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 178 times
Been thanked: 344 times
Contact:

#22

Post by Nayam » Sat Mar 09, 2019 2:38 pm

UPDATE!
I just got an AV Cable and tried it, it worked!! The AV Output is working, the box works great and there are no issues but HDMI still gives no signal. Tried cleaning the ports and all but HDMI doesn't work.
Does anybody know if repair shops replace hdmi ports or not?
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!
My Devices:
X96 Mini, A95X Pro, H96 Pro Stick, A95X Max

Meakai
Verified Member
Posts: 10
Joined: Sat Mar 09, 2019 8:28 pm
Has thanked: 2 times
Been thanked: 1 time

#23

Post by Meakai » Sat Mar 09, 2019 8:49 pm

Hi,
This has happened to me on more than one occasion. The culprit is usually the HDMI cable. Try using different HDMI cables and different TVs or monitors before concluding that the HDMI port is faulty.

Nayam  
Administrator & Developer
Posts: 1236
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 178 times
Been thanked: 344 times
Contact:

#24

Post by Nayam » Sat Mar 09, 2019 10:21 pm

Oh god, this is weird :')
This might sound strange but I finally found the problem!!!πŸ™πŸ˜‚πŸ˜…
Here's what I did,
The HDMI port was fine, it was perfectly soldered and everything. Then I tried to see the logic board, I saw the lines going to the processor. The processor is glued to the heatsink, the heatsink cannot come off because of the glue.
So, I figured out the problem, It had to be the processor. But without taking the heatsink off, the only option left was putting pressure on the processor.
I pushed the box from top and bottom centre and guess what?
IT FREAKING WORKED!!
It shows hdmi output when I put pressure on the processor. Probably, the heatsink cannot put pressure on the box and that's why the processor fails to work properly, in this case, to show hdmi output.

So, for anybody wondering if your hdmi ports are not working. Put pressure on the processor and check. The pressure has to be uniform so press the box from top and bottom centre while the case is closed.
To make this effect permanent, I'm going to put some paper inside it it so that it gets congested and works.

Will mark this topic as solved if the workaround works.
Thanks to everybody who helped!πŸ™
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!
My Devices:
X96 Mini, A95X Pro, H96 Pro Stick, A95X Max

Nayam  
Administrator & Developer
Posts: 1236
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 178 times
Been thanked: 344 times
Contact:

#25

Post by Nayam » Sat Mar 09, 2019 10:26 pm

SrWladimir wrote: ↑
Sun Feb 17, 2019 8:13 am
This will sound stupid, but you can try if you don't have anything to lose,
If you have a Heat gun, try to use it on the MOBO for a 15 seconds..
I say this because happened to me on various hardware that GPU soldering is not well made and it makes it power on but no video output or powers on but can't boot because of the GPU.
Again, only try this at last option and if you don't have anything to lose.
If you will try this, take off any plastic part and any heatsink.
You were right all along, Heatgun will work but I don't have one. I'll see if I can get it, thanks a lot!
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!
My Devices:
X96 Mini, A95X Pro, H96 Pro Stick, A95X Max

User avatar
SrWladimir
Verified Member
Posts: 44
Joined: Fri Feb 01, 2019 9:44 pm
Has thanked: 15 times
Been thanked: 3 times

#26

Post by SrWladimir » Sat Mar 09, 2019 10:33 pm

Nayam wrote: ↑
Sat Mar 09, 2019 10:26 pm
SrWladimir wrote: ↑
Sun Feb 17, 2019 8:13 am
This will sound stupid, but you can try if you don't have anything to lose,
If you have a Heat gun, try to use it on the MOBO for a 15 seconds..
I say this because happened to me on various hardware that GPU soldering is not well made and it makes it power on but no video output or powers on but can't boot because of the GPU.
Again, only try this at last option and if you don't have anything to lose.
If you will try this, take off any plastic part and any heatsink.
You were right all along, Heatgun will work but I don't have one. I'll see if I can get it, thanks a lot!
How are you so sure it will work if you didn't try it yet?

Nayam  
Administrator & Developer
Posts: 1236
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 178 times
Been thanked: 344 times
Contact:

#27

Post by Nayam » Sat Mar 09, 2019 10:37 pm

SrWladimir wrote: ↑
Sat Mar 09, 2019 10:33 pm
Nayam wrote: ↑
Sat Mar 09, 2019 10:26 pm
SrWladimir wrote: ↑
Sun Feb 17, 2019 8:13 am
This will sound stupid, but you can try if you don't have anything to lose,
If you have a Heat gun, try to use it on the MOBO for a 15 seconds..
I say this because happened to me on various hardware that GPU soldering is not well made and it makes it power on but no video output or powers on but can't boot because of the GPU.
Again, only try this at last option and if you don't have anything to lose.
If you will try this, take off any plastic part and any heatsink.
You were right all along, Heatgun will work but I don't have one. I'll see if I can get it, thanks a lot!
How are you so sure it will work if you didn't try it yet?
I've seen TVs getting repaired. When the hdmi doesn't work, the display chip needs refixing or the resistors are faulty. If the display chip is faulty, they put pressure on the chip to test the display and if it works, they apply heat on it to fix it permanently.
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!
My Devices:
X96 Mini, A95X Pro, H96 Pro Stick, A95X Max

User avatar
SrWladimir
Verified Member
Posts: 44
Joined: Fri Feb 01, 2019 9:44 pm
Has thanked: 15 times
Been thanked: 3 times

#28

Post by SrWladimir » Sat Mar 09, 2019 10:40 pm

Nayam wrote: ↑
Sat Mar 09, 2019 10:37 pm
SrWladimir wrote: ↑
Sat Mar 09, 2019 10:33 pm
Nayam wrote: ↑
Sat Mar 09, 2019 10:26 pm
You were right all along, Heatgun will work but I don't have one. I'll see if I can get it, thanks a lot!
How are you so sure it will work if you didn't try it yet?
I've seen TVs getting repaired. When the hdmi doesn't work, the display chip needs refixing or the resistors are faulty. If the display chip is faulty, they put pressure on the chip to test the display and if it works, they apply heat on it to fix it permanently.
Good to know it is still alive, but have in mind that this may not work if the chip haves the shittiest ever soldering, if that is the case, you may need reballing it, that will be hard to do

Nayam  
Administrator & Developer
Posts: 1236
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 178 times
Been thanked: 344 times
Contact:

#29

Post by Nayam » Sat Mar 09, 2019 10:47 pm

SrWladimir wrote: ↑
Sat Mar 09, 2019 10:40 pm
Nayam wrote: ↑
Sat Mar 09, 2019 10:37 pm
SrWladimir wrote: ↑
Sat Mar 09, 2019 10:33 pm
How are you so sure it will work if you didn't try it yet?
I've seen TVs getting repaired. When the hdmi doesn't work, the display chip needs refixing or the resistors are faulty. If the display chip is faulty, they put pressure on the chip to test the display and if it works, they apply heat on it to fix it permanently.
Good to know it is still alive, but have in mind that this may not work if the chip haves the shittiest ever soldering, if that is the case, you may need reballing it, that will be hard to do
Well, I tried to heat the mobo
Now, no display at allπŸ˜‚πŸ˜­πŸ˜­
I'll let it cool down and try after a few hours to see if putting pressure still works or not. The paper thing did work great tho, kind of regretting nowπŸ˜‚
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!
My Devices:
X96 Mini, A95X Pro, H96 Pro Stick, A95X Max

User avatar
SrWladimir
Verified Member
Posts: 44
Joined: Fri Feb 01, 2019 9:44 pm
Has thanked: 15 times
Been thanked: 3 times

#30

Post by SrWladimir » Sat Mar 09, 2019 10:50 pm

Nayam wrote: ↑
Sat Mar 09, 2019 10:47 pm
SrWladimir wrote: ↑
Sat Mar 09, 2019 10:40 pm
Nayam wrote: ↑
Sat Mar 09, 2019 10:37 pm
I've seen TVs getting repaired. When the hdmi doesn't work, the display chip needs refixing or the resistors are faulty. If the display chip is faulty, they put pressure on the chip to test the display and if it works, they apply heat on it to fix it permanently.
Good to know it is still alive, but have in mind that this may not work if the chip haves the shittiest ever soldering, if that is the case, you may need reballing it, that will be hard to do
Well, I tried to heat the mobo
Now, no display at allπŸ˜‚πŸ˜­πŸ˜­
I'll let it cool down and try after a few hours to see if putting pressure still works or not. The paper thing did work great tho, kind of regretting nowπŸ˜‚
Don't heat the entire MOBO, just the chip that haves the issue, if you try to heat the entire MOBO, it will be worse

Post Reply