Image

Amazon Prime on V2F?

TX3 Mini, X96 Mini, W95 to name a few...
Post Reply
gutster
Posts: 7
Joined: Sun Jul 22, 2018 6:59 pm
Been thanked: 1 time

Amazon Prime on V2F?

Post by gutster » Thu Sep 27, 2018 8:22 pm

Hey I installed the new V2F on my X96 Mini and wanted to stream Prime Video on it but it doesnt load the videos. I starts loading but than goes back to the main Page.

Is this still a bug or do I need a special Prime Video App?

User avatar
Nayam
Administrator & Developer
Posts: 647
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 77 times
Been thanked: 102 times
Contact:

Post by Nayam » Fri Sep 28, 2018 3:03 pm

gutster wrote:
Thu Sep 27, 2018 8:22 pm
Hey I installed the new V2F on my X96 Mini and wanted to stream Prime Video on it but it doesnt load the videos. I starts loading but than goes back to the main Page.

Is this still a bug or do I need a special Prime Video App?
You need widevine L1 which your box doesn't have
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!

Manuel
Posts: 4
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 1 time

Post by Manuel » Fri Sep 28, 2018 8:32 pm

But the Prime Video apk from the Play Store runs perfectly with the stock rom of the x96 mini.
Same thing with another apps of TV channels....

jeanrhum
Posts: 1
Joined: Sat Nov 24, 2018 2:57 pm

Post by jeanrhum » Sat Nov 24, 2018 3:02 pm

Hi,

I have similar problems with prime video. Normally Widevine L1 is only mandatory for 4K streaming (as for netflix).
I burnt latest S912 img yesterday on a Tap pro (2G/16G) and it works very well, but prime video does not launch video. With the previous rom (another one grabbed on freaktab), I was able to use prime video without any issue but on android rom (not atv).

bobbyskills
Verified Member
Posts: 13
Joined: Wed Dec 05, 2018 3:26 pm

Post by bobbyskills » Wed Dec 05, 2018 3:28 pm

Has anyone gotten Amazon Prime Video to work on the V2F or V2FF yet?

User avatar
Nayam
Administrator & Developer
Posts: 647
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 77 times
Been thanked: 102 times
Contact:

Post by Nayam » Thu Dec 06, 2018 10:27 am

bobbyskills wrote:
Wed Dec 05, 2018 3:28 pm
Has anyone gotten Amazon Prime Video to work on the V2F or V2FF yet?
I don't have prime subscription but I want to fix the prime error.
I think it happens because of build.prop configuration.
Try comparing it with your previous rom's build.prop
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!

kick
Verified Member
Posts: 23
Joined: Tue Dec 18, 2018 1:51 pm
Been thanked: 1 time

Post by kick » Tue Dec 18, 2018 2:06 pm

Hi, I have the following: HK1 TV Box (Android 7.1) with 2GB RAM 16GB ROM Amlogic S905W Quad Core A53 64 Bits, Supporting 4K (60Hz) Full HD/3D/H.265/WiFi 2.4GH.

For some reason it locked up on me last week and I couldn't get to the recovery screen so I took a chance on flashing V2FF via USB method and it worked perfectly! :grinning:

The only issue I seem to have is this one with Amazon Prime Video where it starts loading the video and returns to the main page. I had no issues with Prime Video before the box was bricked. Unfortunately, I don't have a copy of the old build.prop file.

Any help in getting this issue resolved would be appreciated.

User avatar
Nayam
Administrator & Developer
Posts: 647
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 77 times
Been thanked: 102 times
Contact:

Post by Nayam » Tue Dec 18, 2018 2:08 pm

Amazon confirmed that they're restricting their app only to work in certified devices.
Anybody can confirm this? Can you run amazon prime in stock firmwares?
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!

kick
Verified Member
Posts: 23
Joined: Tue Dec 18, 2018 1:51 pm
Been thanked: 1 time

Post by kick » Tue Dec 18, 2018 2:32 pm

Hi Nayam, I doubt my HK1 is on their list of certified devices. It's just a generic Chinese made box. It did however play Amazon Prime Video just fine until the box became bricked last week. I then flashed V2FF and most things seem to work fine although I haven't tested Netflix (don't have an account) or ethernet. My iptv apps, kodi, wifi... all seem to work fine except for Prime Video.

Havock
Posts: 3
Joined: Wed Dec 19, 2018 8:19 pm

Post by Havock » Wed Dec 19, 2018 8:23 pm

kick wrote:
Tue Dec 18, 2018 2:06 pm
Hi, I have the following: HK1 TV Box (Android 7.1) with 2GB RAM 16GB ROM Amlogic S905W Quad Core A53 64 Bits, Supporting 4K (60Hz) Full HD/3D/H.265/WiFi 2.4GH.

For some reason it locked up on me last week and I couldn't get to the recovery screen so I took a chance on flashing V2FF via USB method and it worked perfectly! :grinning:
Weird I have the same box and it did the exact same thing right around the same time.
Mostly just sits there with the Red power light showing, if it gets tot he Blue light the screen just stays at the MBOX logo.

I was trying to find the firmware for this box to flash it when I stumbled on your post. Other than the Amazon issue, is V2F worth installing? Hoping to resurrect my HK1.

Post Reply