[HELP] x96 mini 2GB/16GB Red Light only After Flash

TX3 Mini, X96 Mini, W95 to name a few...
Posts: 3
Joined: Tue Sep 08, 2020 1:30 pm

[HELP] x96 mini 2GB/16GB Red Light only After Flash


Post by aian0306 » Sat Oct 17, 2020 7:28 am

I will appreciate your assistance/help. I'm currenty lost and can't think of any solution. Good or bad comments, i will consider it as a gift. TIA

I bought a new x96 mini 2/16(supposed to be ,I'm not so sure)
I installed couple of applications to verify if it is a real 2'/16 device

-Diskinfo = 2/16
-Aid64 = 2/16
-CPUZ= 2/16
-FakeDeviceTest= 2/16
-RamTruth= 2/16

Every single one of them says it was 2GB/16GB device (I'm sure that it was 16 GB EMMC ,but i had my doubts with the ram)

We all know(atleast most of us will agree) that the stock firmware/rom installed is somewhat crap or I can say a PAIN in the ***. So I decided maybe I can replace the firmware instead(I know s905w isn't that great since it was S905x underpowered chip) but it is not that bad either.

I decided to Flash the ATVexperince(I'm not blaming anybody, this is my choice and action, so I'm the one to blame why my device was screwed up).

##########(side-story) While downloading the ATVexperience rom , I decided to try COREELEC , since it is available as Dual Boot, so I Flashed COREELEC in my spare SDCARD(sandisk Ultra 32gb)

Tried it on my x96 mini .
It won't boot at all(tried all DTB)

#########Back to the main story

Download was finished but I was doubting that there may be some error if i flash the ATVexperience since it wont Boot with COREELEC. I installed Terminal Emulator and checked the Device tree .

So ..I was in a trance when the result came out.
Terminal emulator says "gxl|_p281_1g"

Now I'm confused. But that did not stopped me from flashing the rom

And then that led me to "RED LIGHT NO BOOT" device .

I just wanna include that the device was still detectable by my PC/laptop But when Flashing it will indicate ERROR at 1%

My PC/laptop (i triied PC and laptop) can detect the device, I tried every sequence for flashing

-Load firmware -connect the device - Click Start = error @ 1%
-Load firmware -Click Start -Connect the Device = error @ 1%
-Connect the Device -Load firmware -Click Start = error @ 1%

I Tried
-Shorting Pin (even the device is detected)
-Reset Button - USB connect
-USB connect - Reset Button - Power Supply

Dragging this all way down, Still led me to Bricked device

PS: Tried Diffent Stock Firmware, no luck

-No Recovery
-NO SD boot




This topic has 6 replies

You must be a registered member and logged in to view the replies in this topic.

Register Login