[DISCUSSION] Sunvell T95Z Max TV Box

H96 Pro, X98 Pro, TX9 Pro to name a few...
Post Reply
bumerc
Moderator
Posts: 118
Joined: Tue Oct 02, 2018 6:19 pm
Has thanked: 3 times
Been thanked: 10 times

[DISCUSSION] Sunvell T95Z Max TV Box

Post by bumerc » Wed Nov 28, 2018 11:34 am

Nayam wrote:
Wed Nov 28, 2018 10:41 am
etzka wrote:
Wed Nov 28, 2018 10:27 am
bumerc wrote:
Wed Nov 28, 2018 5:23 am

Try replacing the dtb file. Or send me the link to download the FW that works on your box.
You speak about this file - "_aml_dtb.PARTITION"? How and when replace that?
http://www.mediafire.com/file/u931juyh4 ... -v1076.rar
Replace it in level 1 folder.
Yes.
You can also install it in the u-boot-Terminal

Code: Select all

mmcinfo; fatload mmc 0:1 0x01080000 _aml_dtb.PARTITION
store dtb write 0x01080000
reset

etzka
Experienced Member
Posts: 74
Joined: Sat Sep 15, 2018 11:10 am
Has thanked: 1 time
Been thanked: 2 times

Post by etzka » Wed Nov 28, 2018 5:36 pm

Finally istalled firmware, @bumerc . What I've done to look at it that apps are working, no apps crashing, wifi works, but original IR remote not working. System freezes at some point, and then reboot not helping. I have in u-boot write "reset", then system loading normaly till next system freeze.

bumerc
Moderator
Posts: 118
Joined: Tue Oct 02, 2018 6:19 pm
Has thanked: 3 times
Been thanked: 10 times

Post by bumerc » Thu Nov 29, 2018 8:11 am

...but original IR remote not working. System freezes at some point, and then reboot not helping. I have in u-boot write "reset", then system loading normaly till next system freeze.
Could you please post the log

etzka
Experienced Member
Posts: 74
Joined: Sat Sep 15, 2018 11:10 am
Has thanked: 1 time
Been thanked: 2 times

Post by etzka » Thu Nov 29, 2018 1:24 pm

bumerc wrote:
Thu Nov 29, 2018 8:11 am
...but original IR remote not working. System freezes at some point, and then reboot not helping. I have in u-boot write "reset", then system loading normaly till next system freeze.
Could you please post the log
Strange, but all day there were no issues :) just this one, cec
The problems are:
IR remote not workink(no big deal, I have airmouse)
Problems with hdmi cec function. When I turn off tv with original IR tv remote, my box sleep too(thats good), when again I immediately turn on tv with original remote, box wake up too(thats good), but when more time passed, like 5min or more, box dont wake up(thats bad). With airmouse box dont wakeup too all the time. Then I pull down and up power, but the box dont booting into os, stuck on atvx logo. One more or two times I did this and box booting normaly.
Here is log when stuck on boot
https://pastebin.com/fXhQTwcm

bumerc
Moderator
Posts: 118
Joined: Tue Oct 02, 2018 6:19 pm
Has thanked: 3 times
Been thanked: 10 times

Post by bumerc » Fri Nov 30, 2018 3:22 pm

Hi, I found a few bugs, but I have no time to deal with them at the moment. Regarding original remote control - temporarily use the shutdown mode, activate it in the settings.

etzka
Experienced Member
Posts: 74
Joined: Sat Sep 15, 2018 11:10 am
Has thanked: 1 time
Been thanked: 2 times

Post by etzka » Fri Nov 30, 2018 3:35 pm

bumerc wrote:
Fri Nov 30, 2018 3:22 pm
Hi, I found a few bugs, but I have no time to deal with them at the moment. Regarding original remote control - temporarily use the shutdown mode, activate it in the settings.
Hi, thanks for help , for now I dont use cec function at all, but yours suggestion good too.

bumerc
Moderator
Posts: 118
Joined: Tue Oct 02, 2018 6:19 pm
Has thanked: 3 times
Been thanked: 10 times

Post by bumerc » Sat Dec 01, 2018 2:55 pm

@etzka

new uboot, enable HDMI CEC and test it again.

u-boot.bin

Installation:

Code: Select all

mmcinfo; fatload mmc 0 ${loadaddr} u-boot.bin
store rom_write ${loadaddr} 0 100000
defenv
saveenv
reset

etzka
Experienced Member
Posts: 74
Joined: Sat Sep 15, 2018 11:10 am
Has thanked: 1 time
Been thanked: 2 times

Post by etzka » Sun Dec 02, 2018 11:53 am

This is with issues too. When I power off tv with original tv IR remote, box sleep too, but when I power on tv, box dont wake up. I have 3 or 4 times plug box power to boot normaly, without stuck. Airmouse work some time(sleep, wakeup, but afterall just stop worked)
First two booting with stuck https://pastebin.com/Lf0eR2Ub
https://pastebin.com/Nb1wVwnZ
Third time box booted automaticaly into twrp recovery, then from there I restarted into system.
Besides that, there would be good, if original box IR remote able to work, and led clock etc :)

bumerc
Moderator
Posts: 118
Joined: Tue Oct 02, 2018 6:19 pm
Has thanked: 3 times
Been thanked: 10 times

Post by bumerc » Sun Dec 02, 2018 2:17 pm

2160p50hz ... vout=2160p50hz,enable hdmimode=2160p50hz
Why does this resolution appear now, default setting in the uboot is 1080p60hz .. You have not modified anything? I have to check your dtb. The remaining problems caused the front display (I still need time :) )
Regarding HDMI CEC - did you switch back to standby mode in the settings?

etzka
Experienced Member
Posts: 74
Joined: Sat Sep 15, 2018 11:10 am
Has thanked: 1 time
Been thanked: 2 times

Post by etzka » Sun Dec 02, 2018 2:24 pm

bumerc wrote:
Sun Dec 02, 2018 2:17 pm
2160p50hz ... vout=2160p50hz,enable hdmimode=2160p50hz
Why does this resolution appear now, default setting in the uboot is 1080p60hz .. You have not modified anything? I have to check your dtb. The remaining problems caused the front display (I still need time :) )
Regarding HDMI CEC - did you switch back to standby mode in the settings?
Why 2160p, because my tv is 4K (my tv automaticaly changed it to 4k resolution). Yes I switched back to sleep mode.
Here is my dtb http://s000.tinyupload.com/index.php?fi ... 2476912873
Another problem is with video playing. Sometimes when I start to play video, screen goes black, and then my tv shows that there is no hdmi connection, I quickly press back button a lot off time and the android view comes back, sometimes not.. Sometimes box restarting, and goes to 1/4 screen, other screen is black. I think box resolution switch to 1080p, but tv stays on 4k.

Post Reply