Smart Youtube TV App Uninstall

appXperience
t_beasley
Posts: 4
Joined: Fri Oct 26, 2018 1:31 am
Been thanked: 1 time

Smart Youtube TV App Uninstall

#1

Post by t_beasley » Tue Feb 12, 2019 3:39 am

Hi folks,

The package name has changed for the Smart Youtube TV app. It's asking to uninstall the old package, but because it is installed as a system app it can't just be simply uninstalled. The first thing I tried was to disable the old package, but the new package still detects it as installed. I then tried to use ES File Manager's root uninstaller and my box reboots unexpectedly and into a strange resolution that makes the screen very small. So, I installed Magisk and Titanium Backup to try to uninstall it that way. When I try to uninstall it using Titanium Backup, it gives me the error message, "Failed to Locate .apk"

I'm all out of ideas, any help is greatly appreciated.

Asya2017
Verified Member
Posts: 19
Joined: Fri Nov 23, 2018 5:22 am
Has thanked: 1 time
Been thanked: 5 times

#2

Post by Asya2017 » Tue Feb 12, 2019 5:16 am

Please use "system app remover". It has a red icon. and tv box must be rooted.

User avatar
ricklar
Moderator
Posts: 806
Joined: Fri Nov 30, 2018 10:30 pm
Has thanked: 120 times
Been thanked: 226 times

#3

Post by ricklar » Tue Feb 12, 2019 10:04 am

t_beasley wrote:
Tue Feb 12, 2019 3:39 am
The package name has changed for the Smart Youtube TV app.
...
I'm all out of ideas, any help is greatly appreciated.
First my question to you is, this so-called update is from an internal Auto-Update within the Smart-YouTube apk???

I updated Smart-YouTube a couple days ago and it didn't change package name. Install was smooth no issues.

If you are downloading and trying to install an update that has been "Modded" is the only reason I could think the package name to be changed. Where either the modder didn't know what they where doing?! Or you have downloaded a malware apk.

I will check again my version of Smart-YouTube sometime today.
BE KIND, BE NICE, BE RESPECTFUL TO OTHERS, RESPECT THE MODERATORS,
*IMPORTANT NOTE* ONLY PM MODERATORS OR DEVELOPERS AS A LAST RESORT!!!

☢️ My test device: H96 Pro+ 3gb/32gb DDR4 ☢️ Plus own Tanix, Beelink, Alfawise, X96S
GEARBEST.com
PLEASE ENJOY ATVX!

User avatar
ricklar
Moderator
Posts: 806
Joined: Fri Nov 30, 2018 10:30 pm
Has thanked: 120 times
Been thanked: 226 times

#4

Post by ricklar » Tue Feb 12, 2019 1:59 pm

Update: the new Smart YouTube update was a massive update :grin: The app doubled in size with it also changing it's package name and standard mobile icon changed. (S-YouTube app is even more optimized for AndroidTV OS)
t_beasley wrote:
Tue Feb 12, 2019 3:39 am
The first thing I tried was to disable the old package, but the new package still detects it as installed.
At this point you have 2 apks of S-YouTube app installed in your device. And if the prompt to update keeps appearing then you are still opening the old app version. Edit: Will be two identical SmartYouTube icons in LeanbackLauncher, scroll right to end of App list to see new installed version.
t_beasley wrote:I then tried to use ES File Manager's root uninstaller and my box reboots unexpectedly and into a strange resolution that makes the screen very small. So, I installed Magisk and Titanium Backup to try to uninstall it that way. When I try to uninstall it using Titanium Backup, it gives me the error message, "Failed to Locate .apk"
So I don't know what's going on in your TVbox according to those sentences above, box should have been rooted already, no needed for Magisk unless you unrooted the box with download Unroot.zip

If Magisk root is now correctly installed, with the Manager apk installed just grant a root explorer like EsFile Explorer SuperUser Permissions and uninstall original apk through EsFile Explorer, verify version numbers so you don't delete the new one.

Note:
Whenever uninstalling system apks or installing system apk updates, always REBOOT device after uninstall or install.
Also, it doesn't hurt anything to have both versions of the SmartYouTube installed. The old system apk version could always be disabled in Android Settings.
BE KIND, BE NICE, BE RESPECTFUL TO OTHERS, RESPECT THE MODERATORS,
*IMPORTANT NOTE* ONLY PM MODERATORS OR DEVELOPERS AS A LAST RESORT!!!

☢️ My test device: H96 Pro+ 3gb/32gb DDR4 ☢️ Plus own Tanix, Beelink, Alfawise, X96S
GEARBEST.com
PLEASE ENJOY ATVX!

t_beasley
Posts: 4
Joined: Fri Oct 26, 2018 1:31 am
Been thanked: 1 time

#5

Post by t_beasley » Tue Feb 12, 2019 9:29 pm

Having both on the box always prompts the new version to uninstall the old version, then the new version either opens or closes. Disabling the old app doesn't prompt the new app to try to update, but brings me to the uninstall screen, which I can't do.

I've already tried "system app remover". It looks like the app is removed but on reboot it is back.

I had to install magisk because there's something wrong with the binaries if I don't. At least that's the error titanium backup throws when I open it without installing magisk. And it gives me no options in titanium if I don't install magisk. It still throws the bad binaries error when magisk is installed, but I get options.

Nayam
Administrator & Developer
Posts: 1240
Joined: Mon Jun 11, 2018 11:58 pm
Has thanked: 178 times
Been thanked: 347 times
Contact:

#6

Post by Nayam » Fri Feb 15, 2019 8:22 am

t_beasley wrote:
Tue Feb 12, 2019 9:29 pm
Having both on the box always prompts the new version to uninstall the old version, then the new version either opens or closes. Disabling the old app doesn't prompt the new app to try to update, but brings me to the uninstall screen, which I can't do.

I've already tried "system app remover". It looks like the app is removed but on reboot it is back.

I had to install magisk because there's something wrong with the binaries if I don't. At least that's the error titanium backup throws when I open it without installing magisk. And it gives me no options in titanium if I don't install magisk. It still throws the bad binaries error when magisk is installed, but I get options.
Sorry, my bad. I was managing the builds till v2ff, if s youtube was installed as system app sorry for that. I won't include it as a system app in next build.
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!
My Devices:
X96 Mini, A95X Pro, H96 Pro Stick, A95X Max

hannah
Experienced Member
Posts: 50
Joined: Sun Jan 20, 2019 11:15 pm
Has thanked: 4 times
Been thanked: 4 times

#7

Post by hannah » Sat Feb 16, 2019 3:06 am

ricklar wrote:
Tue Feb 12, 2019 1:59 pm

If Magisk root is now correctly installed, with the Manager apk installed just grant a root explorer like EsFile Explorer SuperUser Permissions and uninstall original apk through EsFile Explorer, verify version numbers so you don't delete the new one.
I simply uninstall the system app sYoutube via root explorer within EsFile Explorer.
Post that restarted the tv box and now I only have 1 sYoutube apk.

Cheers

youpie
Posts: 2
Joined: Sun Feb 17, 2019 5:54 pm

#8

Post by youpie » Sun Feb 17, 2019 6:14 pm

First of all, thank you very much for this wonderfull tv android rom. Put it on x96 mini. Tank you for the advice: how to root and put twrp on it. Now I can backup and put it on my 2gb/16gb x96 mini. I am so happy :heart_eyes:

youpie
Posts: 2
Joined: Sun Feb 17, 2019 5:54 pm

#9

Post by youpie » Sun Feb 17, 2019 6:18 pm

One more thing. I took .kodi out of the list of my old device and put it here on kodi 18, because there was no possibillity to restore with any addon. Usb wizzard, indigo or +ez. Perhaps that help someone. :grin:

User avatar
AxEgo
Experienced Member
Posts: 95
Joined: Tue Nov 27, 2018 5:34 am
Has thanked: 6 times
Been thanked: 28 times

#10

Post by AxEgo » Mon Feb 18, 2019 3:44 am

You have to backup kodi separately. There is a backup addon in the official kodi repository.
X96 Mini - S905W - 2/16GB ATVXperience v2F

Post Reply