Amazon Prime problems

appXperience
kick
Verified Member
Posts:23
Joined:Tue Dec 18, 2018 1:51 pm
Been thanked: 1 time
Amazon Prime on V2F?

#11

Post by kick » Thu Dec 20, 2018 12:57 pm

Havock wrote:
Wed Dec 19, 2018 8:23 pm
kick wrote:
Tue Dec 18, 2018 2:06 pm
Hi, I have the following: HK1 TV Box (Android 7.1) with 2GB RAM 16GB ROM Amlogic S905W Quad Core A53 64 Bits, Supporting 4K (60Hz) Full HD/3D/H.265/WiFi 2.4GH.

For some reason it locked up on me last week and I couldn't get to the recovery screen so I took a chance on flashing V2FF via USB method and it worked perfectly! :grinning:
Weird I have the same box and it did the exact same thing right around the same time.
Mostly just sits there with the Red power light showing, if it gets tot he Blue light the screen just stays at the MBOX logo.

I was trying to find the firmware for this box to flash it when I stumbled on your post. Other than the Amazon issue, is V2F worth installing? Hoping to resurrect my HK1.
Absolutely worth it for me as I couldn't get past the MBOX logo either, no matter what I tried. I flashed with the most recent firmware for S905W (V2FF not V2F) using USB method with male to male cable and it revived my box. I find the atvXperience UI to be better than the stock firmware that was on this box. Note that I haven't tested everything but wifi, and the apps I need, work perfectly. I believe the atvXperience team are aware of the Prime Video issue and are working on it, so that may get solved in the near future too.

stef07
Posts:1
Joined:Sat Jan 05, 2019 1:52 pm

#12

Post by stef07 » Sat Jan 05, 2019 1:57 pm

Hi,
I've installed the Firmware on a Bolv S912 and it works well.
I've an issue with Amazon Prime Video - Android TV. When I try to play a film, it starts to buffer a bunch of time and then it stop saying "internet connection not available".
Have you any hints about? I can provide debug logs, if you tell me how gather them.

Nayam
Administrator & Developer
Posts:1259
Joined:Mon Jun 11, 2018 11:58 pm
Has thanked: 192 times
Been thanked: 390 times
Contact:

#13

Post by Nayam » Sat Jan 05, 2019 5:56 pm

stef07 wrote:
Sat Jan 05, 2019 1:57 pm
Hi,
I've installed the Firmware on a Bolv S912 and it works well.
I've an issue with Amazon Prime Video - Android TV. When I try to play a film, it starts to buffer a bunch of time and then it stop saying "internet connection not available".
Have you any hints about? I can provide debug logs, if you tell me how gather them.
This is a drm issue, team contacted amazon and they said they're restricting the app to certified devices only.
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!
My Devices:
X96 Mini, A95X Pro, H96 Pro Stick, A95X Max

diback
Posts:2
Joined:Tue Feb 19, 2019 6:31 am

#14

Post by diback » Tue Feb 19, 2019 7:24 am

Nayam wrote:
Tue Dec 18, 2018 2:08 pm
Amazon confirmed that they're restricting their app only to work in certified devices.
Anybody can confirm this? Can you run amazon prime in stock firmwares?
Yes Prime Video working fine on Stock Rom x96 mini 7.12 (http://www.filefactory.com/file/2mmv4at ... INI%20.rar)

earth08
Posts:3
Joined:Wed Feb 27, 2019 9:47 am

#15

Post by earth08 » Sun Mar 31, 2019 4:34 am

Dear,
I downloaded the latest prime video from aptoide and its working on minim8s2 s905c

User avatar
ricklar
Moderator
Posts:879
Joined:Fri Nov 30, 2018 10:30 pm
Has thanked: 133 times
Been thanked: 248 times

#16

Post by ricklar » Sun Mar 31, 2019 5:31 am

earth08 wrote:
Sun Mar 31, 2019 4:34 am
Dear,
I downloaded the latest prime video from aptoide and its working on minim8s2 s905c
S905C???
So you are using a stock firmware TVbox?

I believe because the AtvX firmware is androidTV OS, that the Amazon apk is doing device checks and reading TV OS present that it looks for DRM L1, which all factory certified TV OS devices contain. Which is why in a stock firmware tv box with basic(mobile) android OS the mobile Prime Video apks will run with only DRM L3.
BE KIND, BE NICE, BE RESPECTFUL TO OTHERS, RESPECT THE MODERATORS,
*IMPORTANT NOTE* ONLY PM MODERATORS OR DEVELOPERS AS A LAST RESORT!!!

☢️ My test device: H96 Pro+ 3gb/32gb DDR4 ☢️ Plus own Tanix, Beelink, Alfawise, X96S, Odroid-N2, Khadas VIM3L, X3, ADT-3, X96-Air
GEARBEST.com
PLEASE ENJOY ATVX!

User avatar
Parsival
Verified Member
Posts:20
Joined:Sun Jan 27, 2019 1:54 am
Been thanked: 2 times

#17

Post by Parsival » Sun Mar 31, 2019 4:35 pm

Mini M8s II is a S905X... I have 2 of these

earth08
Posts:3
Joined:Wed Feb 27, 2019 9:47 am

#18

Post by earth08 » Tue Apr 02, 2019 8:15 am

Sorry typing mistake
Mini M8s2 s905x

warrior666
Posts:1
Joined:Tue Apr 02, 2019 11:33 am

#19

Post by warrior666 » Tue Apr 02, 2019 11:42 am

I have 2 box X96 with S905X, on one with stock firmware Prime is ok, the other with atvxperience firmware, Prime app try to start the video and stucks. It says me there isn't enough band, i try connect with lan cable but same. On both devices i check drm widevine, both have L3 security. So the problem is in the os i think.

Nayam
Administrator & Developer
Posts:1259
Joined:Mon Jun 11, 2018 11:58 pm
Has thanked: 192 times
Been thanked: 390 times
Contact:

#20

Post by Nayam » Wed Apr 03, 2019 7:14 am

warrior666 wrote:
Tue Apr 02, 2019 11:42 am
I have 2 box X96 with S905X, on one with stock firmware Prime is ok, the other with atvxperience firmware, Prime app try to start the video and stucks. It says me there isn't enough band, i try connect with lan cable but same. On both devices i check drm widevine, both have L3 security. So the problem is in the os i think.
This is certainly a problem either with esn or something else, I'll try my best to make it work in v3
BE NICE, BE RESPECTFUL
RESPECT THE MODERATORS
PM ONLY WHEN IMPORTANT
ENJOY!
My Devices:
X96 Mini, A95X Pro, H96 Pro Stick, A95X Max

Post Reply