[LINUX][TOOL] Android 9.0 partition repack tool!

Post your great articles here :)
Post Reply
oldman20
Verified Member
Posts: 17
Joined: Sat May 14, 2022 4:23 pm
Answers: 0
Has thanked: 4 times

#51

bumerc wrote: Mon Nov 02, 2020 8:14 am
ath156 wrote: Mon Nov 02, 2020 6:50 am Is it OK to update to a newer version of Ubuntu (as I got a message for doing it)?
Basically yes, you only have to install the android-tools-fsutils package, as it is no longer available under these package names in newer Ubuntu versions..
i ran that cmd but result is:

Code: Select all

$ sudo apt install android-tools-fsutils
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package android-tools-fsutils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  android-sdk-libsparse-utils

E: Package 'android-tools-fsutils' has no installation candidate
Then i install instead, is it fine?

Code: Select all

$ sudo apt install android-sdk-libsparse-utils
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
android-sdk-libsparse-utils is already the newest version (1:10.0.0+r36-9).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
bumerc
Administrator & Developer
Posts: 1551
Joined: Tue Oct 02, 2018 6:19 pm
Answers: 0
Has thanked: 211 times
Been thanked: 334 times

#52

oldman20 wrote: Tue May 17, 2022 1:43 am Then i install instead, is it fine?
Yes.
I will check it and make an update if necessary..
oldman20
Verified Member
Posts: 17
Joined: Sat May 14, 2022 4:23 pm
Answers: 0
Has thanked: 4 times

#53

bumerc wrote: Wed May 18, 2022 9:08 am
oldman20 wrote: Tue May 17, 2022 1:43 am Then i install instead, is it fine?
Yes.
I will check it and make an update if necessary..
Thank you, glad to hear that :blush:
oldman20
Verified Member
Posts: 17
Joined: Sat May 14, 2022 4:23 pm
Answers: 0
Has thanked: 4 times

#54

bumerc wrote: Wed May 18, 2022 9:08 am
oldman20 wrote: Tue May 17, 2022 1:43 am Then i install instead, is it fine?
Yes.
I will check it and make an update if necessary..
I tried many times and superSU always 5.8kb, I download manual then put in afck/ingredients then run make mod-supersu but always error
Image

Code: Select all

make mod-supersu
mkdir -p "bc-tool/stamp"
#mkdir -p bc-tool/system/system/system/app/SuperSU
#unzip -qojp  common/Superuser.apk > bc-tool/system/system/system/app/SuperSU/SuperSU.apk
# Пропатчим SuperSU
#  @echo -e 'Patching APK file bc-tool/system/system/system/app/SuperSU/SuperSU.apk'
java -jar tools/apktool_2.4.0.jar decode -o out/amlogic/device/1-2g/patch-SuperSU.apk -f bc-tool/system/system/system/app/SuperSU/SuperSU.apk
Input file (bc-tool/system/system/system/app/SuperSU/SuperSU.apk) was not found or was not readable.
make: *** [build/mod.mak:62: bc-tool/stamp/.stamp.mod-supersu] Error 1

Doesn't exist out/amlogic/device/1-2g/patch-SuperSU.apk, and bc-tool/stamp/.stamp.mod-supersu is 0kb, what's wrong Sir?

And I found a video about this tool, but it not mention make mod-supersu command, which i really need
https://www.youtube.com/watch?v=exDD6YOC4HU
Thank Sir!
Do you have a telegram channel? I really need your help
bumerc
Administrator & Developer
Posts: 1551
Joined: Tue Oct 02, 2018 6:19 pm
Answers: 0
Has thanked: 211 times
Been thanked: 334 times

#55

@oldman20
You have to edit the corresponding *.mak file and comment out the following lines

Code: Select all

mkdir -p bc-tool/system/system/system/app/SuperSU
unzip -qojp  common/Superuser.apk > bc-tool/system/system/system/app/SuperSU/SuperSU.apk
@echo -e 'Patching APK file bc-tool/system/system/system/app/SuperSU/SuperSU.apk'
java -jar tools/apktool_2.4.0.jar decode -o out/amlogic/device/1-2g/patch-SuperSU.apk -f bc-tool/system/system/system/app/SuperSU/SuperSU.apk
__________
Posts: 4
Joined: Tue Jul 20, 2021 2:13 pm
Answers: 0
Has thanked: 1 time

#56

Can someone reupload the latest version (bc-tool-update-pie-q-02b), i can't find it anywhere else and the mega.nz link is not working Thanks
User avatar
em3ka
Moderator
Posts: 1836
Joined: Sun Jul 15, 2018 11:43 am
Answers: 0
Has thanked: 108 times
Been thanked: 371 times

#57

bc-tool-02b.zip
You do not have the required permissions to view the files attached to this post.
__________
Posts: 4
Joined: Tue Jul 20, 2021 2:13 pm
Answers: 0
Has thanked: 1 time

#58

em3ka wrote: Sun Sep 25, 2022 7:05 pmbc-tool-02b.zip
Thanks
__________
Posts: 4
Joined: Tue Jul 20, 2021 2:13 pm
Answers: 0
Has thanked: 1 time

#59

can this tool be used in other editions like ubuntu Xfce or just ubuntu?
User avatar
em3ka
Moderator
Posts: 1836
Joined: Sun Jul 15, 2018 11:43 am
Answers: 0
Has thanked: 108 times
Been thanked: 371 times

#60

It depends on your Linux knowledge, i presume that should run on most of the distros - tested on Ubuntu.
- Installation on Ubuntu >= 18.04 64bit (VirtualBox on Windows is supported)
https://forum.freaktab.com/node/803627
Post Reply