[HELP] MXQ PRO clone (MXQ_S95X_V2_0)

MiBox, X96 to name a few...
Post Reply
jimjack12
Posts: 4
Joined: Sat Jun 05, 2021 2:12 pm

#1

Hello to the whole Forum.
I don't know if this is the correct section, but I have an MXQ 1/8 Gb Cpu S905X (I think it's a clone ...) all black in brick.
- I tried to flash with USB_Burning_Tool (different versions: 3.1, 2.2, etc ....);
- I tried to change usb cable
- I have tried flashing with several Roms, including "atvXperience v4", "HQYG-TX7-nikodi-20180104", and many others;
- I tried two notebooks, one with win 10 64bit and the other with win 7 64bit
Unfortunately I always get the same error and everything crashes at 4%.
I attach the photos of the error and of the mainboard, maybe someone can give me some suggestions, such as short-circuit the pins of the nand, or something like that.
Thanks so much
You do not have the required permissions to view the files attached to this post.
User avatar
em3ka
Moderator
Posts: 1716
Joined: Sun Jul 15, 2018 11:43 am
Has thanked: 128 times
Been thanked: 357 times

#2

jimjack12 wrote: Sun Jun 06, 2021 1:26 pm I have tried flashing with several Roms, including "atvXperience v4"...
Finding the right firmware for MXQ devices (so many versions), is like looking for a needle in a haystack, wi-fi 9082C chip is not supported under v4, try with atvX v2FF version
or with this stock firmware...
https://chinagadgetsreviews.com/downloa ... v-box.html
During the flashing, also connect power cord to the device.
jimjack12
Posts: 4
Joined: Sat Jun 05, 2021 2:12 pm

#3

Thank you very much for your availability @em3ka.
Unfortunately neither of the two roms worked, same 4% blocking problem.
Yes, to make the flash, I must necessarily insert the USB cable and the power supply. I also tried to insert first one and then the other and vice versa, but nothing .....
You're absolutely right: it's like looking for a needle in a haystack ...
Is there a way to short the nand pins? Or is it just a compatibility problem of the Rom?
Thanks so much
Last edited by jimjack12 on Sun Jun 13, 2021 8:38 am, edited 2 times in total.
jimjack12
Posts: 4
Joined: Sat Jun 05, 2021 2:12 pm

#4

Good morning to the whole Forum.
If it helps, I found the box of the box and on the label is:
OTT TV BOX
X000N2ZCNN
ITFBA-MXQ-S905X
GooBang Doo IT MXQ 6.0
Thanks so much for any suggestions
User avatar
mxfreak
Experienced Member
Posts: 64
Joined: Tue Mar 19, 2019 1:14 pm
Has thanked: 25 times
Been thanked: 2 times

#5

It looks i have the same problems,see my topic today.

I have a geekbuying box 2gb is one gb (fakebox),the fw there was working with UB tool and also some atv old fw was working with some weird behaviors.(see my old topics from 2019)

Where buyed? ya know? then ask for support fw.
Post Reply