H96 Pro Plus Black PCB with HS2734A Wifi WORKING ATVxperience v2H

H96 Pro, X98 Pro, TX9 Pro to name a few...
demhaha
Posts: 6
Joined: Sun Jul 08, 2018 2:43 am
Has thanked: 3 times
Been thanked: 2 times

#11

bumerc wrote: Sun Apr 14, 2019 6:50 pm [mention]demhaha[/mention]
This build (above) uses a different amlogic-dt-id, which will result in a 100% install abort if it does not match the dt-id in the preinstalled (original) uboot. Please tell me your current amlogic-dt-id.

Use this command to get the current aml-dt-id:

Code: Select all

cat /proc/device-tree/amlogic-dt-id
I ran the command above through Termux on the stock firmware and yielded the following:

Image
bumerc
Administrator & Developer
Posts: 1649
Joined: Tue Oct 02, 2018 6:19 pm
Has thanked: 254 times
Been thanked: 342 times

#12

demhaha wrote: Sun Apr 14, 2019 7:35 pm
bumerc wrote: Sun Apr 14, 2019 6:50 pm [mention]demhaha[/mention]
This build (above) uses a different amlogic-dt-id, which will result in a 100% install abort if it does not match the dt-id in the preinstalled (original) uboot. Please tell me your current amlogic-dt-id.

Use this command to get the current aml-dt-id:

Code: Select all

cat /proc/device-tree/amlogic-dt-id
I ran the command above through Termux on the stock firmware and yielded the following:

Image
aml_upgrade_package.img
demhaha
Posts: 6
Joined: Sun Jul 08, 2018 2:43 am
Has thanked: 3 times
Been thanked: 2 times

#13

bumerc wrote: Sun Apr 14, 2019 6:50 pm aml_upgrade_package.img
Thank you very much for your help! I now have it up and running.

Definitely some quirks with this build:

Splash screen reads H96 Pro+ and runs the stock android animation upon booting in stead of the atvxperience splash and animation.

Recent apps screen runs like android for mobile as opposed to ATV.

Same issue as [mention]rico2019[/mention] where google play store reads "This version of the app isn't compatible with your device. To fix this problem, go to Settings and uninstall updates for the Google Play Store app."

But the wifi seems to be working great and the interface is almost the same, snappy atvxperience I love.

Greatly appreciate your assistance [mention]bumerc[/mention] !!!
bumerc
Administrator & Developer
Posts: 1649
Joined: Tue Oct 02, 2018 6:19 pm
Has thanked: 254 times
Been thanked: 342 times

#14

So far, I've only updated the bootloader and dtb, removed manufacturer restrictions, I will update the bootlogo in the next version and install support for both h96pp and m96xp devices simultaneously.
demhaha
Posts: 6
Joined: Sun Jul 08, 2018 2:43 am
Has thanked: 3 times
Been thanked: 2 times

#15

bumerc wrote: Mon Apr 15, 2019 3:30 am So far, I've only updated the bootloader and dtb, removed manufacturer restrictions, I will update the bootlogo in the next version and install support for both h96pp and m96xp devices simultaneously.
Let me know if you need help testing with my device. I can't say I'm at all knowledgeable about development, but I'm willing to help where and when I can.
amrendrasinha2007
Posts: 1
Joined: Sun Dec 22, 2019 5:34 am

#16

Hi
I downloaded the firmware "H96 Pro Plus Black PCB with HS2734A Wifi WORKING ATVxperience v2H" and installed on h96 Pro h2 s912 stick. Wifi is working but showing poor signal. Bluetooth devices find in result but unable to connect. Google Play store shows incompatible error message. I tried to install latest version but unable to update. After first boot, it runs smoothly. But after second boot, device runs extremely slow. Please help.
Post Reply